WAV files aren’t downloading.


Hi. I’m suddenly having trouble downloading WAV files. I’m using Internet Explorer, as it’s the only browser that’s currently accessible with my screen reader (Firefox just crashes whenever I try to log into the site) and Windows 10. I haven’t had any issues in days. About a week or more. I’ve downloaded loads of WAV files and saved them to an external harddrive, so I don’t think space is the issue.

MP3 files are downloading fine. It’s just the WAV files that have suddenly decided not to work. I’ve got a gold account, so it’s not download points…

I have no idea why it would just stop working. Any help would be extremely appreciated.

Marked as spam
Posted by IrishRowan (Questions: 2, Answers: 1)
Asked on 3rd November 2017 2:30 pm
Private answer


Hmm, that’s strange. Yesterday we had a developer in and working on some aspects of the website but not anything that directly relates to the wav file downloads. Can you confirm if you still have the issue?

Internet Explorer is not the best for using our website but I know one other member using a screen reader had issue because there is a second download link on a pop up for when certain browsers don’t trigger the download first time.

Can you email me at contact@zapsplat.com if you’re still having issues so we can work through what may be happening for you?

Kind regards


Marked as spam
Posted by Alan McKinney (Questions: 1, Answers: 174)
Answered on 4th November 2017 11:42 am

    Hi, Alan. Thaks so much for your swift reply. Yes, I’m still having issues. I’ll email you though. Usually, something pops up on my screen that’ll ask me to save or download something, though on your site, what would happen was the wav files (as the mp3 files do) just opened in Windows Media Player and I’d save them from there. At the bottom of the page, when I click ‘download wav’ now, either the link beneath the sound on the sound results page or the button on the individual sound page… I just get this.

    If download does not start automatically, click on download button. Okay.

    I’ll click the okay button, or the link above this message that says ‘download wav’ again, but nothing happens.

    I’ve read that IE’s not the best, but it really was doing beautifully before. I’ve restarted my computer loads of times; downloads are working just fine in other places, so something’s just oopsing up here I think. LOL.

    (IrishRowan at 4th November 2017 4:40 pm)

      Thanks for the email. Glad it is all sorted.

      (Alan McKinney at 5th November 2017 9:38 am)